<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />
<meta name="viewport" content="width=device-width" /> 	<link rel="Shortcut Icon" href="https://scotscoop.com/wp-content/uploads/2014/05/favicon.ico" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="Scot Scoop News RSS 2.0" href="https://scotscoop.com/feed/" />
<link rel="alternate" type="text/xml" title="Scot Scoop News RSS .92" href="https://scotscoop.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Scot Scoop News Atom 0.3" href="https://scotscoop.com/feed/atom/" />

<title>The latest episode of ‘Rick and Morty’ lives up to its expectations &#8211; Scot Scoop News</title>
		<style type="text/css">			.tweeter-info .fts-twitter-text, .fts-twitter-reply-wrap:before, a span.fts-video-loading-notice {
				color: #222 !important;
			}

						.tweeter-info .fts-twitter-text a, .tweeter-info .fts-twitter-text .time a, .fts-twitter-reply-wrap a, .tweeter-info a, .twitter-followers-fts a, body.fts-twitter-reply-wrap a {
				color: #140aa3 !important;
			}

						.tweeter-info a:hover, .tweeter-info:hover .fts-twitter-reply, body.fts-twitter-reply-wrap a:hover {
				color: #ddd !important;
			}

						.fts-twitter-div {
				max-width: 500px !important;
			}

						.fts-twitter-div {
				margin: 10px !important;
			}

						.fts-twitter-div {
				padding: 10px !important;
			}

						.fts-twitter-div {
				background: #ddd !important;
			}

						.tweeter-info {
				border-bottom: 1px solid #ddd !important;
			}

						.fts-twitter-link-image {
				max-width: 500px !important;
				display: block;
			}

						span.fts-twitter-text {
				font-size: 12px !important;
			}

			
		</style>
		<link rel="alternate" type="application/rss+xml" title="Scot Scoop News &raquo; The latest episode of ‘Rick and Morty’ lives up to its expectations Comments Feed" href="https://scotscoop.com/time-to-chew-choo-up-the-latest-episode-of-rick-and-morty/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/scotscoop.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			<style type="text/css">
				</style>
	<link rel='stylesheet' id='farbtastic-css'  href='https://scotscoop.com/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://scotscoop.com/wp-includes/css/dashicons.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://scotscoop.com/wp-includes/js/thickbox/thickbox.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://scotscoop.com/wp-content/plugins/instagram-feed/css/sb-instagram-2-2.min.css?ver=2.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://scotscoop.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://scotscoop.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://scotscoop.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://scotscoop.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://scotscoop.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpda_form_gutenberg_css-css'  href='https://scotscoop.com/wp-content/plugins/contact-forms-builder/wpdevart-inc/gutenberg/style.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='smuzform-public-form-render-css'  href='https://scotscoop.com/wp-content/plugins/contact-form-add/public/assets/css/form-style.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='content-slider-css-css'  href='https://scotscoop.com/wp-content/plugins/content-grid-slider/css/content-slider-style.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='fts-feeds-css'  href='https://scotscoop.com/wp-content/plugins/feed-them-social/feeds/css/styles.css?ver=2.8.3.3' type='text/css' media='' />
<link rel='stylesheet' id='image-hover-effects-css-css'  href='https://scotscoop.com/wp-content/plugins/mega-addons-for-visual-composer/css/ihover.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='style-css-css'  href='https://scotscoop.com/wp-content/plugins/mega-addons-for-visual-composer/css/style.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-latest-css'  href='https://scotscoop.com/wp-content/plugins/mega-addons-for-visual-composer/css/font-awesome/css/all.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='sow-image-default-17bc2272b535-css'  href='https://scotscoop.com/wp-content/uploads/siteorigin-widgets/sow-image-default-17bc2272b535.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='sow-contact-form-default-c29a12d6fd11-css'  href='https://scotscoop.com/wp-content/uploads/siteorigin-widgets/sow-contact-form-default-c29a12d6fd11.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-background-video-css'  href='https://scotscoop.com/wp-content/plugins/video-backgrounds-for-siteorigin-page-builder/assets/jquery.background-video.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='so_video_background-css'  href='https://scotscoop.com/wp-content/plugins/video-backgrounds-for-siteorigin-page-builder/assets/so_video_background.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://scotscoop.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.4' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://scotscoop.com/wp-content/plugins/wp-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700%7CRoboto+Condensed%3A400%2C700%7CRoboto%3A400%2C700&#038;display=swap&#038;ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://scotscoop.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20191203' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://scotscoop.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://scotscoop.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://scotscoop.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://scotscoop.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://scotscoop.com/wp-content/themes/snoflex/style.css?ver=20200557' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css'  href='https://scotscoop.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.0.7' type='text/css' media='screen' />
<script type='text/javascript' src='https://scotscoop.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/plugins/content-grid-slider/js/content-slider.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/plugins/feed-them-social/feeds/js/powered-by.js?ver=2.8.3.3'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/plugins/feed-them-social/feeds/js/fts-global.js?ver=2.8.3.3'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/plugins/mega-addons-for-visual-composer/js/script.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/plugins/so-widgets-bundle/widgets/contact/js/contact.min.js?ver=1.16.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=20190826'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/scotscoop.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20200505'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.4.1'></script>
<link rel='https://api.w.org/' href='https://scotscoop.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://scotscoop.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://scotscoop.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Apodcalypse Ep. 3: Quarantine cat-tastrophe' href='https://scotscoop.com/apodcalypse-ep-3-quarantine-cat-tastrophe/' />
<link rel='next' title='How Good Is Your Knowledge On Love Trivia?' href='https://scotscoop.com/how-good-is-your-knowledge-on-love-trivia/' />
<meta name="generator" content="WordPress 5.4.1" />
<link rel="canonical" href="https://scotscoop.com/time-to-chew-choo-up-the-latest-episode-of-rick-and-morty/" />
<link rel='shortlink' href='https://scotscoop.com/?p=215440' />
<link rel="alternate" type="application/json+oembed" href="https://scotscoop.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fscotscoop.com%2Ftime-to-chew-choo-up-the-latest-episode-of-rick-and-morty%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://scotscoop.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fscotscoop.com%2Ftime-to-chew-choo-up-the-latest-episode-of-rick-and-morty%2F&#038;format=xml" />
	<style type="text/css" media="all">.shortcode-star-rating{padding:0 0.5em;}.dashicons{font-size:20px;width:auto;height:auto;line-height:normal;text-decoration:inherit;vertical-align:middle;}.shortcode-star-rating [class^="dashicons dashicons-star-"]:before{color:#FCAE00;}.ssr-int{margin-left:0.2em;font-size:13px;vertical-align:middle;color:#333;}/*.shortcode-star-rating:before,.shortcode-star-rating:after{display: block;height:0;visibility:hidden;content:"\0020";}.shortcode-star-rating:after{clear:both;}*/</style>
	

<!-- Start of Facebook Meta Tags -->

<meta property="og:title" content="The latest episode of ‘Rick and Morty’ lives up to its expectations" />
<meta property="og:type" content="article" />
<meta name="author" content="Polina Engovatov" />
<meta property="og:url" content="https://scotscoop.com/time-to-chew-choo-up-the-latest-episode-of-rick-and-morty/" />
<meta property="og:image" content="https://scotscoop.com/wp-content/uploads/2020/05/24894378477_00a9d21952_o-1-e1588974718481-900x644.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="644" />
	<meta property="og:site_name" content="Scot Scoop News" />
	<meta property="og:description" content="After a long wait, the second half of season four has finally started to air.  Back in 2018, co-producer of the show Justin Roiland tweeted out that there were 70 more episodes to come. Yet one year later, near the end of 2019, only five episodes were released. Finally, amid a global pandemic, part two..." />
	<meta name="description" content="After a long wait, the second half of season four has finally started to air.  Back in 2018, co-producer of the show Justin Roiland tweeted out that there were 70 more episodes to come. Yet one year later, near the end of 2019, only five episodes were released. Finally, amid a global pandemic, part two..." />
	<meta property="article:section" content="Reviews" />
	<meta property="article:tag" content="" />
<!-- End of Facebook Meta Tags -->

<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://scotscoop.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/

.bottom-menu{
	display: table;
	margin: 0 auto;
	text-align: center;
	min-width: 878px;
}
		</style>
		<style id="tt-easy-google-font-styles" type="text/css">p { }
h1 { }
h2 { }
h3 { }
h4 { }
h5 { }
h6 { }
</style><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>

<script>
	jQuery(document).ready(function() {
		var wpadminbar = jQuery('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if (jQuery('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
			
		
		
	
	});
</script>


<style type="text/css" media="screen">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</style>
</head>

<body data-rsssl=1 class="sno-animate-active"><div class="topnavwrap">
	<div id="topnavbar">
			
			<div class="search-spacer"></div>

			<div class="topnavbarleft social-classic">
				<style>.topnavbarleft { padding: 0px; width:auto; }</style><a target="_blank" href="https://scotscoop.com/feed/rss/"><div class="alt-header-social social-border sno-rss dashicons dashicons-rss"><span class="icon-hidden-text">RSS Feed</span></div></a><a target="_blank" href="https://www.youtube.com/HighlanderScotScoop">
        		<div class="alt-header-social-fa social-border sno-youtube fa fa-youtube-play"><span class="icon-hidden-text">YouTube</span></div>
        	</a><a target="_blank" href="https://www.instagram.com/scot.scoop/">
        		<div class="alt-header-social-fa social-border sno-instagram fa fa-instagram"><span class="icon-hidden-text">Instagram</span></div>
        	</a><a target="_blank" href="https://twitter.com/scotscoop">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a target="_blank" href="https://facebook.com/CarlmontHighlander">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div>			</div>

			<div class="topnavbarcenter">
                    <script src="https://scotscoop.com/wp-content/themes/snoflex/javascript/date.js" type="text/javascript"></script>
        			</div>
	
			<div class="topnavbarright">
					<form method="get" id="searchform281" action="https://scotscoop.com/">
			<div class="search-button-container" id="searchthis281">
			<button type="submit" disabled="disabled" id="sno-search-navbar-281" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s281" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s281" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit281" style="display:none;" value="Search" />
		</form>
				</div>
	</div>
	<div class="clear"></div>
</div><div id="sno_mobile_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search-side"><div class="sno-side-menu side-close-icon foundation-icons fi-x"><span class="icon-hidden-text">Close Menu</span></div><form method="get" class="searchform-alt-left" action="https://scotscoop.com/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-mobile" class="menu"><li id="menu-item-46225" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-46225"><a href="https://scotscoop.com/">Home</a></li>
<li id="menu-item-46373" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46373"><a href="https://scotscoop.com/category/slider/">Top News</a></li>
<li id="menu-item-46231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46231"><a href="https://scotscoop.com/category/recent-news/">News</a></li>
<li id="menu-item-46235" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46235"><a href="https://scotscoop.com/category/sports/">Sports</a></li>
<li id="menu-item-46236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46236"><a href="https://scotscoop.com/category/campus/">Campus</a></li>
<li id="menu-item-75078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75078"><a href="https://scotscoop.com/category/features/">Features</a></li>
<li id="menu-item-75079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75079"><a href="https://scotscoop.com/category/opinion/">Opinion</a></li>
<li id="menu-item-75077" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-75077"><a href="https://scotscoop.com/category/reviews/">Reviews</a></li>
<li id="menu-item-77259" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77259"><a href="https://scotscoop.com/category/scot-center/">ScotCenter</a></li>
<li id="menu-item-211844" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-211844"><a href="https://scotscoop.com/category/covid-19/">COVID-19</a></li>
</ul></div></ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="https://scotscoop.com/wp-content/uploads/2020/02/phonebanner-2.jpg" class="headerimage" alt="The student news site of Carlmont High School in Belmont, California." /></div><div class="headerlink headermedium" style="display:none"><img src="https://scotscoop.com/wp-content/uploads/2020/02/Screen-Shot-2020-02-07-at-2.47.38-PM.png" class="headerimage" alt="The student news site of Carlmont High School in Belmont, California." /></div><div class="headerlink headerlarge"><img src="https://scotscoop.com/wp-content/uploads/2020/02/Screen-Shot-2020-02-07-at-2.47.38-PM.png" class="headerlink headerimage" alt="The student news site of Carlmont High School in Belmont, California." /></div><h1 style="display:none" aria-hidden="true">Scot Scoop News</h1><script type="text/javascript">
						jQuery(document).ready(function(){
							jQuery(".headerlink").click(function(){
								window.location="https://scotscoop.com";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon dashicons dashicons-menu"><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div>				<script type="text/javascript">
					jQuery(document).ready(function() {
						jQuery(".newsticker3-jcarousellite").jCarouselLite({
        					vertical: true,
        					visible: 1,
        					auto:4000,
        					speed:2000    					});
					});
				</script><div class="breakingnewswrap"><div id="breakingnews"><div id="newsticker3-demo"><div class="newsticker3-jcarousellite"><ul><li><div class="info"><span class="bndate">May 3</span><span class='breakingnewsheadline'><a href='https://scotscoop.com/diversity-in-mass-media-remains-an-issue/'>Editor's Choice: Diversity in mass media remains an issue</a></span></div><div class="clear"></div></li><li><div class="info"><span class="bndate">May 1</span><span class='breakingnewsheadline'><a href='https://scotscoop.com/once-and-future-artfully-blends-sci-fi-and-historical-fiction-together/'>Editor's Choice: ‘Once and Future’ artfully blends sci-fi and historical fiction together</a></span></div><div class="clear"></div></li><li><div class="info"><span class="bndate">April 30</span><span class='breakingnewsheadline'><a href='https://scotscoop.com/remembering-the-columbine-high-school-massacre/'>Editor's Choice: Remembering the Columbine High School massacre</a></span></div><div class="clear"></div></li></ul></div></div></div></div><div class="clear"></div><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://scotscoop.com"><img src="https://scotscoop.com/wp-content/uploads/2020/02/Screen-Shot-2020-02-07-at-2.47.38-PM.png" class="headerimage" alt="The student news site of Carlmont High School in Belmont, California." /></a></div><h1 style="display:none">Scot Scoop News</h1></div></div><div class="bottom-menu"><div class='subnavbarwrap'
						data-align='center' 
						data-margin='0' 
						data-style='Bar' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='40px' 
						data-width='1290'><div class="subnavbarcontainer"><div id="subnavbar"><div id="subnavbarbackground"><div id="menu-b-menu"><nav aria-label="Main Menu"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="sf-menu sno-bottom-menu"><li id="menu-item-30121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30121"><a href="https://scotscoop.com/category/recent-news/">News</a></li>
<li id="menu-item-30357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30357"><a href="https://scotscoop.com/category/sports/">Sports</a></li>
<li id="menu-item-30133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30133"><a href="https://scotscoop.com/category/campus/">Campus</a></li>
<li id="menu-item-53129" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53129"><a href="https://scotscoop.com/category/features/">Features</a></li>
<li id="menu-item-30130" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30130" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://scotscoop.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-71127" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-71127"><a href="https://scotscoop.com/category/reviews/">Reviews</a></li>
	<li id="menu-item-191894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191894"><a href="https://scotscoop.com/category/opinion/editorials/">Editorials</a></li>
	<li id="menu-item-204558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204558"><a href="https://scotscoop.com/category/standalone-cartooning/">Cartoons</a></li>
	<li id="menu-item-212462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212462"><a href="https://scotscoop.com/category/blogs/">Blogs</a></li>
</ul>
</li>
<li id="menu-item-87995" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-87995" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://scotscoop.com/category/scot-center/">ScotCenter</a>
<ul class="sub-menu">
	<li id="menu-item-204893" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204893"><a href="https://scotscoop.com/category/scot-center/scotcenterpodcasts/">Podcasts</a></li>
	<li id="menu-item-211050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-211050"><a href="https://scotscoop.com/category/scot-center/vlogs/">Vlogs</a></li>
</ul>
</li>
<li id="menu-item-209681" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-209681"><a href="https://scotscoop.com/category/covid-19/">COVID-19</a></li>
</ul></div></nav><div class="clear"></div></div><ul id='menu-more-bottom' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-bottom" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
							<ul id="add-more-bottom" class="sub-menu"></ul>
							</li>
						</ul></div><div class="clear"></div></div></div></div></div><div class="clear"></div><div id="fullwrap" style="position:relative;"><div id="outerbackgroundwrap"><div class="innerbackgroundwrap"><div class="innerbackground"><div id='snopostid-215440' class='snopostid'><div id='storypage' class='full-width sno-story-215440'><div id="content"><div id='contentleft'><div class="postarea"><div role="main"><h1 id="storyheadline" class="storyheadline">The latest episode of ‘Rick and Morty’ lives up to its expectations</h1><div id="storymeta" class="storymeta"><p> <a href="https://scotscoop.com/staff_profile/polina-engovatov/" class="creditline">Polina Engovatov</a>, Staff Writer<span class="storydate"><span class="byline-divider">|</span><span class="time-wrapper">May 13, 2020</span></span></p></div><div class="permalinkphotobox"><div class="storyshadow"><div class="photowrap"><a class='modal-photo photooverlay' data-story-id='215440' data-photo-id='215438' href='#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/05/24894378477_00a9d21952_o-1-e1588974718481-900x644.jpg' alt='Rick+and+Morty+watch+television.+' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photo photo-enlarge elusive el-icon-zoom-in' data-story-id='215440' data-photo-id='215438'></div></div><div class="clear"></div><div class="captionboxmit"><p class="photocredit">The World Needs a Rick and Morty Game / BagoGames / Flickr / CC by 2.0</p><p class="photocaption">Rick and Morty watch television. </p></div></div></div><span class="storycontent"><p><span style="font-weight: 400;">After a long wait, the second half of season four has finally started to air. </span></p>
<p><span style="font-weight: 400;">Back in 2018, co-producer of the show Justin Roiland tweeted out that there were </span><a href="https://twitter.com/JustinRoiland/status/994614321266147328?ref_src=twsrc%5Etfw%7Ctwcamp%5Etweetembed%7Ctwterm%5E994614321266147328&amp;ref_url=https%3A%2F%2Fwww.nme.com%2Fblogs%2Fnme-blogs%2Frick-and-morty-season-4-release-date-plot-and-everything-we-know-so-far-2146711"><span style="font-weight: 400;">70 more episodes to come</span></a><span style="font-weight: 400;">. Yet one year later, near the end of 2019, only five episodes were released. Finally, amid a global pandemic, part two of season four has started to air. </span></p>
<p><span style="font-weight: 400;">“Never Ricking Morty” had very many plot twists, which made the episode much more intriguing. Usually, when there are several plot twists in a short amount of time, it is relatively hard to follow the general flow of an episode. However, in this rare situation, none of the plot twists were even slightly confusing to the viewer. </span></p>
<p><span style="font-weight: 400;">‘</span><a href="https://www.amazon.com/Edge-Tomorty-Rick-Die-Rickpeat/dp/B07Z2DZD62/ref=sr_1_1?crid=148XT5PRCF289&amp;dchild=1&amp;keywords=rick+and+morty&amp;qid=1588968767&amp;sprefix=rick+and+mor%2Caps%2C305&amp;sr=8-1#customer-review-section"><span style="font-weight: 400;">Rick and Morty</span></a><span style="font-weight: 400;">’ episodes are known for their unrealistic fictional adventures with scientific elements. The most recent episode was quite average considering no major event happened that could change the course of the entire season; however, nevertheless, it was an interesting side story. </span></p>
<p><span style="font-weight: 400;">Most episodes in all the seasons would still make sense to watch even without prior knowledge of what happens in the show. This one was no exception. Mad scientist Rick, a drunk genius, worked hard like always to solve the mystery of this episode and try to escape the story train that he and his grandson Morty were stuck on. </span></p>
<p><span style="font-weight: 400;">Though important side characters like Summer or Jerry were not featured just yet in the second half of the season, the plot nevertheless was exciting and fun to follow. No one could make fun of Jerry’s stupidity in this episode; however, that was made up for by the thrill of the plot. A new character is also introduced, the story master, who added to the entertainment of the episode greatly. </span></p>
<p><span style="font-weight: 400;">Another reason why many people enjoy watching the show is that some events or aspects of it are left up to the viewer’s interpretation. This also allows for the various fan clubs to create theories as to what is happening and what might happen in the future. As an example, concerning this specific episode, many theories have been created in regards to the </span><a href="https://rickandmorty.fandom.com/wiki/Council_of_Ricks"><span style="font-weight: 400;">Council of Ricks</span></a><span style="font-weight: 400;">.</span></p>
<p><span style="font-weight: 400;">It goes without saying that as the rest of season four comes out, fans will continue to be excited just like they were for this episode. </span></p>
</span></div><div class="clear"></div><div class="sharing sharing-top" data-story-id="215440"><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fscotscoop.com%2Ftime-to-chew-choo-up-the-latest-episode-of-rick-and-morty%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=The latest episode of ‘Rick and Morty’ lives up to its expectations&amp;url=https%3A%2F%2Fscotscoop.com%2F%3Fp%3D215440&amp;via=scotscoop" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//scotscoop.com/time-to-chew-choo-up-the-latest-episode-of-rick-and-morty//?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Print</span></div></a></div><ul class="snocategories"><li class='blockscategory'><a href='https://scotscoop.com/category/reviews/' rel='category tag'>Reviews</a></li></ul><div class="aboutwriter"><div class='aboutwritertitle'>About the Writer</div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><div class='sc_photo'><img src='https://scotscoop.com/wp-content/uploads/2019/09/Paulina-Engovatov-Profile-475x317.jpg' alt='Photo of Polina Engovatov'/></div><a href="https://scotscoop.com/staff_profile/polina-engovatov/"><div class='sc_title'>Polina Engovatov, Staff Writer</div></a><div class='sc_bio'>Polina Engovatov is a sophomore at Carlmont High School and this is her first year in Media Arts English. She plays golf and lacrosse for her school, and enjoys STEM classes like math and physics.<br />
<br />
Twitter: @polinanaa<div class='clear'></div></div></div><div class="clear"></div></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div tabindex="0" role="button" aria-expanded="false" class="commenttoggle fa fa-plus-square"></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id='commentsbody' class='widgetbody' style='display:none;'>


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">
We invite comments and responses to our content. Comments that are deemed appropriate and relevant will be published.<br /><br />
If you want a picture to show with your comment, go get a <a href="https://en.gravatar.com">gravatar</a>.</p>





<form action="https://scotscoop.com/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							jQuery(function(){
								jQuery('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="215440" /></p>



<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="386767a192" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="166"/></p>


</form>









</div></div><div class="widgetfooter"></div></div></div></div><div class="clear"></div><div class="relatedstories"><div class="storymeta" style="margin-bottom:0px;"><p style="text-align:center;font-size:16px;line-height:30px;"><a href="https://scotscoop.com/category/reviews/">Reviews</a></p></div><div class="relatedbody"><div class='catrow catstory-position-1'><a href="https://scotscoop.com/board-game-reviews-istanbul/" title="Board Game Reviews: Istanbul"><img src="https://scotscoop.com/wp-content/uploads/2020/05/IMG_4864-240x150.jpg" class="catstory-photo" alt="Board Game Reviews: Istanbul" /></a><h5 class="relatedtitle"><a href="https://scotscoop.com/board-game-reviews-istanbul/">Board Game Reviews: Istanbul</a></h5></div><div class='relateddividervert catstory-position-2'></div><div class='catrow catstory-position-2'><a href="https://scotscoop.com/our-planet-rounds-out-netflixs-collection-of-documentaries/" title="&#8216;Our Planet&#8217; rounds out Netflix’s collection of documentaries"><img src="https://scotscoop.com/wp-content/uploads/2020/05/Great_barrier_reef-240x150.jpg" class="catstory-photo" alt="&#8216;Our Planet&#8217; rounds out Netflix’s collection of documentaries" /></a><h5 class="relatedtitle"><a href="https://scotscoop.com/our-planet-rounds-out-netflixs-collection-of-documentaries/">&#8216;Our Planet&#8217; rounds out Netflix’s collection of documentaries</a></h5></div><div class='relateddividervert catstory-position-3'></div><div class='catrow catstory-position-3'><a href="https://scotscoop.com/newly-released-netflix-series-outer-banks-brings-forth-relatable-characters-but-a-typical-storyline/" title="Newly-released Netflix series &#8216;Outer Banks&#8217; brings forth relatable characters but a typical storyline"><img src="https://scotscoop.com/wp-content/uploads/2020/05/IMG_0499-240x150.jpg" class="catstory-photo" alt="Newly-released Netflix series &#8216;Outer Banks&#8217; brings forth relatable characters but a typical storyline" /></a><h5 class="relatedtitle"><a href="https://scotscoop.com/newly-released-netflix-series-outer-banks-brings-forth-relatable-characters-but-a-typical-storyline/">Newly-released Netflix series &#8216;Outer Banks&#8217; brings forth relatable characters but a typical storyline</a></h5></div><div class='relateddividervert catstory-position-4'></div><div class='catrow catstory-position-4'><a href="https://scotscoop.com/31st-union-serves-food-for-comfort/" title="31st Union serves food for comfort"><img src="https://scotscoop.com/wp-content/uploads/2020/05/6FD20D46-F00C-477B-BE8E-555C717DC214-240x150.jpg" class="catstory-photo" alt="31st Union serves food for comfort" /></a><h5 class="relatedtitle"><a href="https://scotscoop.com/31st-union-serves-food-for-comfort/">31st Union serves food for comfort</a></h5></div><div class='relateddividervert catstory-position-5'></div><div class='catrow catstory-position-5'><a href="https://scotscoop.com/hidden-trails-of-belmont-are-the-best-around/" title="Hidden trails of Belmont are the best around"><img src="https://scotscoop.com/wp-content/uploads/2020/05/Untitled-1-240x150.jpg" class="catstory-photo" alt="Hidden trails of Belmont are the best around" /></a><h5 class="relatedtitle"><a href="https://scotscoop.com/hidden-trails-of-belmont-are-the-best-around/">Hidden trails of Belmont are the best around</a></h5></div><div class="clear"></div></div></div><div class="clear"></div></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://scotscoop.com/board-game-reviews-istanbul/#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/05/IMG_4864-475x330.jpg' id='grow-stb215306'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The latest episode of ‘Rick and Morty’ lives up to its expectations'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb215306').mouseenter(function() {
   											jQuery('#grow-stb215306').removeClass('shrink');
   											jQuery('#grow-stb215306').removeClass('grow');
   											jQuery('#grow-stb215306').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb215306').addClass('shrink');
   										});});</script><p class='stb-cat'>Blogs</p><p class="relatedtitle"><a href="https://scotscoop.com/board-game-reviews-istanbul/">Board Game Reviews: Istanbul</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://scotscoop.com/our-planet-rounds-out-netflixs-collection-of-documentaries/#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/05/Great_barrier_reef-475x356.jpg' id='grow-stb215433'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The latest episode of ‘Rick and Morty’ lives up to its expectations'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb215433').mouseenter(function() {
   											jQuery('#grow-stb215433').removeClass('shrink');
   											jQuery('#grow-stb215433').removeClass('grow');
   											jQuery('#grow-stb215433').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb215433').addClass('shrink');
   										});});</script><p class='stb-cat'>Reviews</p><p class="relatedtitle"><a href="https://scotscoop.com/our-planet-rounds-out-netflixs-collection-of-documentaries/">&#8216;Our Planet&#8217; rounds out Netflix’s collection of documentaries</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://scotscoop.com/newly-released-netflix-series-outer-banks-brings-forth-relatable-characters-but-a-typical-storyline/#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/05/IMG_0499-475x354.jpg' id='grow-stb214977'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The latest episode of ‘Rick and Morty’ lives up to its expectations'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb214977').mouseenter(function() {
   											jQuery('#grow-stb214977').removeClass('shrink');
   											jQuery('#grow-stb214977').removeClass('grow');
   											jQuery('#grow-stb214977').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb214977').addClass('shrink');
   										});});</script><p class='stb-cat'>Reviews</p><p class="relatedtitle"><a href="https://scotscoop.com/newly-released-netflix-series-outer-banks-brings-forth-relatable-characters-but-a-typical-storyline/">Newly-released Netflix series &#8216;Outer Banks&#8217; brings forth relatable characters but a typical storyline</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://scotscoop.com/31st-union-serves-food-for-comfort/#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/05/6FD20D46-F00C-477B-BE8E-555C717DC214-475x356.jpg' id='grow-stb215271'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The latest episode of ‘Rick and Morty’ lives up to its expectations'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb215271').mouseenter(function() {
   											jQuery('#grow-stb215271').removeClass('shrink');
   											jQuery('#grow-stb215271').removeClass('grow');
   											jQuery('#grow-stb215271').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb215271').addClass('shrink');
   										});});</script><p class='stb-cat'>Reviews</p><p class="relatedtitle"><a href="https://scotscoop.com/31st-union-serves-food-for-comfort/">31st Union serves food for comfort</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://scotscoop.com/hidden-trails-of-belmont-are-the-best-around/#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/05/Untitled-1-475x267.jpg' id='grow-stb215182'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The latest episode of ‘Rick and Morty’ lives up to its expectations'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb215182').mouseenter(function() {
   											jQuery('#grow-stb215182').removeClass('shrink');
   											jQuery('#grow-stb215182').removeClass('grow');
   											jQuery('#grow-stb215182').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb215182').addClass('shrink');
   										});});</script><p class='stb-cat'>Reviews</p><p class="relatedtitle"><a href="https://scotscoop.com/hidden-trails-of-belmont-are-the-best-around/">Hidden trails of Belmont are the best around</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://scotscoop.com/out-of-shadows-questions-our-media/#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/05/Screen-Shot-2020-05-01-at-3.20.00-PM.png' id='grow-stb214719'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The latest episode of ‘Rick and Morty’ lives up to its expectations'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb214719').mouseenter(function() {
   											jQuery('#grow-stb214719').removeClass('shrink');
   											jQuery('#grow-stb214719').removeClass('grow');
   											jQuery('#grow-stb214719').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb214719').addClass('shrink');
   										});});</script><p class='stb-cat'>Reviews</p><p class="relatedtitle"><a href="https://scotscoop.com/out-of-shadows-questions-our-media/">&#8216;Out of Shadows&#8217; questions the foundation of media</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://scotscoop.com/once-and-future-artfully-blends-sci-fi-and-historical-fiction-together/#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/04/IMG-3148-475x346.jpg' id='grow-stb214516'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The latest episode of ‘Rick and Morty’ lives up to its expectations'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb214516').mouseenter(function() {
   											jQuery('#grow-stb214516').removeClass('shrink');
   											jQuery('#grow-stb214516').removeClass('grow');
   											jQuery('#grow-stb214516').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb214516').addClass('shrink');
   										});});</script><p class='stb-cat'>Reviews</p><p class="relatedtitle"><a href="https://scotscoop.com/once-and-future-artfully-blends-sci-fi-and-historical-fiction-together/">‘Once and Future’ artfully blends sci-fi and historical fiction together</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://scotscoop.com/sgn-keeps-good-news-flowing-during-tough-times/#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/04/Some_Good_News.jpg' id='grow-stb214614'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The latest episode of ‘Rick and Morty’ lives up to its expectations'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb214614').mouseenter(function() {
   											jQuery('#grow-stb214614').removeClass('shrink');
   											jQuery('#grow-stb214614').removeClass('grow');
   											jQuery('#grow-stb214614').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb214614').addClass('shrink');
   										});});</script><p class='stb-cat'>Reviews</p><p class="relatedtitle"><a href="https://scotscoop.com/sgn-keeps-good-news-flowing-during-tough-times/">‘SGN’ keeps good news flowing during tough times</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://scotscoop.com/whipped-coffee-lives-up-to-the-buzz/#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/04/IMG-3280-475x356.jpg' id='grow-stb214405'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The latest episode of ‘Rick and Morty’ lives up to its expectations'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb214405').mouseenter(function() {
   											jQuery('#grow-stb214405').removeClass('shrink');
   											jQuery('#grow-stb214405').removeClass('grow');
   											jQuery('#grow-stb214405').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb214405').addClass('shrink');
   										});});</script><p class='stb-cat'>Reviews</p><p class="relatedtitle"><a href="https://scotscoop.com/whipped-coffee-lives-up-to-the-buzz/">Whipped coffee lives up to the buzz</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://scotscoop.com/netflix-gives-fame-to-fast-rising-show-money-heist/#photo'><img src='https://scotscoop.com/wp-content/uploads/2020/04/La_casa_de_papel_intertitle-1.png' id='grow-stb214116'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The latest episode of ‘Rick and Morty’ lives up to its expectations'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb214116').mouseenter(function() {
   											jQuery('#grow-stb214116').removeClass('shrink');
   											jQuery('#grow-stb214116').removeClass('grow');
   											jQuery('#grow-stb214116').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb214116').addClass('shrink');
   										});});</script><p class='stb-cat'>Reviews</p><p class="relatedtitle"><a href="https://scotscoop.com/netflix-gives-fame-to-fast-rising-show-money-heist/">Netflix gives fame to fast-rising show &#8216;Money Heist&#8217;</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 250,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

  							//		animation: 'fade',
  							//		smoothHeight: false,
  							//		customDirectionNav: jQuery("#sfi-navigation span"),
  							//		animationLoop: true,
  							//		slideshow: false,
  							//		touch: true



		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div></div><div style="clear:both;"></div><div class="footerwrap"><div id="footer"><div class="footername"></div><div class="clear"></div><div class="footer-address">SCOT SCOOP<br />
Carlmont High School<br />
1400 Alameda de las Pulgas<br />
Belmont, CA 94002</div><div class="footermenu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-39859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39859"><a href="https://scotscoop.com/about/ssn/">About Us</a></li>
<li id="menu-item-56525" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56525"><a href="https://scotscoop.com/about/contact/">Contact Us</a></li>
<li id="menu-item-58226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58226"><a href="https://scotscoop.com/staff/">Staff</a></li>
<li id="menu-item-78830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78830"><a href="https://feedburner.google.com/fb/a/mailverify?uri=ScotScoopNews&#038;loc=en_US">Subscribe for Updates</a></li>
<li id="menu-item-78818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78818"><a href="https://docs.google.com/document/d/19-1MGX4EY3Sx9HMRO1ZlTYJX57tVUuOthIU7i2E9EeI/edit?usp=sharing">Submit Guest Articles</a></li>
<li id="menu-item-78835" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78835"><a href="https://issuu.com/scotscoop">Read The Highlander</a></li>
<li id="menu-item-58230" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58230"><a href="https://scotscoop.com/useful-links/">Community Links</a></li>
<li id="menu-item-192427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-192427"><a href="https://scotscoop.com/policies/">Carlmont Journalism Policies</a></li>
<li id="menu-item-212409" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-212409"><a href="https://scotscoop.com/takedown-policy/">Takedown Policy</a></li>
</ul></div></div><div class="footercredit"><p><a href="https://scotscoop.com">Scot Scoop News</a> &bull; &copy; 2020 All content is property of Carlmont High School Journalism &bull; <a target='_blank' href='https://snosites.com/client-site-privacy-policy/'>Privacy Policy</a> &bull; <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://scotscoop.com/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-46439551-33', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://scotscoop.com/wp-admin/admin-ajax.php";
</script>
<div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div><script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/scotscoop.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://scotscoop.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/plugins/contact-form-add/public/assets/js/jquery-validate.js?ver=2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var smuzform = {"ajaxurl":"https:\/\/scotscoop.com\/wp-admin\/admin-ajax.php","errorMessages":{"required":"This field is required.","email":"Please enter a valid email address.","number":"The value you have entered is not a numeric value","url":"URL is not valid."}};
/* ]]> */
</script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/plugins/contact-form-add/public/assets/js/smuzforms.js?ver=2.0'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/plugins/video-backgrounds-for-siteorigin-page-builder/assets/jquery.background-video.js?ver=1.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/scotscoop.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://scotscoop.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.4'></script>
<script type='text/javascript' src='https://scotscoop.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script async="async" type='text/javascript' src='https://scotscoop.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.5'></script>
</div><div id="mobile-socialmedia"><div class="sharing sharing-top" data-story-id="215440"><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fscotscoop.com%2Ftime-to-chew-choo-up-the-latest-episode-of-rick-and-morty%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=The latest episode of ‘Rick and Morty’ lives up to its expectations&amp;url=https%3A%2F%2Fscotscoop.com%2F%3Fp%3D215440&amp;via=scotscoop" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//scotscoop.com/time-to-chew-choo-up-the-latest-episode-of-rick-and-morty//?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Print</span></div></a></div></div><div id="sno_hoversearch"><div class="sno-search-close foundation-icons fi-x" style="float:right;"></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://scotscoop.com/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="hover-menu"><div class="sno-menu menu-icon dashicons dashicons-menu"><span class="icon-hidden-text">Menu</span></div><div class="sno-menu close-icon foundation-icons fi-x" style="display:none;"><span class="icon-hidden-text">Close Menu</span></div></div><div id="search-top"><div class="sno-search-button fa fa-search"><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"><div class="sharing sharing-top" data-story-id="215440"><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fscotscoop.com%2Ftime-to-chew-choo-up-the-latest-episode-of-rick-and-morty%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=The latest episode of ‘Rick and Morty’ lives up to its expectations&amp;url=https%3A%2F%2Fscotscoop.com%2F%3Fp%3D215440&amp;via=scotscoop" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//scotscoop.com/time-to-chew-choo-up-the-latest-episode-of-rick-and-morty//?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Print</span></div></a></div></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up fa fa-arrow-up"><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="/"><img src="https://scotscoop.com/wp-content/uploads/2020/02/phonebanner-2.jpg" alt="The student news site of Carlmont High School in Belmont, California." /></a></div><div class="hover_title"><div class="hover_titletext">The latest episode of ‘Rick and Morty’ lives up to its expectations</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://scotscoop.com/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-mobile-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-46225"><a href="https://scotscoop.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46373"><a href="https://scotscoop.com/category/slider/">Top News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46231"><a href="https://scotscoop.com/category/recent-news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46235"><a href="https://scotscoop.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46236"><a href="https://scotscoop.com/category/campus/">Campus</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75078"><a href="https://scotscoop.com/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75079"><a href="https://scotscoop.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-75077"><a href="https://scotscoop.com/category/reviews/">Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77259"><a href="https://scotscoop.com/category/scot-center/">ScotCenter</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-211844"><a href="https://scotscoop.com/category/covid-19/">COVID-19</a></li>
</ul></div></ul></div><script type="text/javascript">
			jQuery(document).ready(function(){
				
	
				function sharingIconsResize() {
					if (jQuery(window).width() < 850) {
						var socialwidth;
						var count = jQuery("#mobile-socialmedia .sharing-mobile-show").length;
						if (count != 0) {
							socialwidth = 100 / count;
							jQuery('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
						}
					} else {
						jQuery('#sno_hoverbar .sharing-icon').width('50px');
					}
				}
									sharingIconsResize();
					
					jQuery(window).resize(function() {
						sharingIconsResize();
					});
								
				jQuery('.sno-search-button').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '0' });
					jQuery('#s-alt').focus();
				});
				jQuery('.sno-search-close').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '-50px' });
				});
	
				var NavScrollTop		= jQuery(window).scrollTop();
	    		
	    		if( jQuery('.navbarwrap').length ) {
	    			var	TopNavOffset 		= jQuery('.navbarwrap').offset().top;
					var TopNavDistance		= (TopNavOffset - NavScrollTop);
	   	 		}
	   	 		if( jQuery('.subnavbarwrap').length ) {
		   	 		var	BottomNavOffset 	= jQuery('.subnavbarwrap').offset().top;
		   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
	   	 		}
	   	 		
	   	 		jQuery('#hoverbar_menu .mobile-menu').height( jQuery(window).height() - 50);
	   	 		
	   	 		var HoverOffset = 0, HoverOffset2 = 0;
					   	 		var HoverHeight = jQuery('#sno_hoverbar').outerHeight();
	   	 		var HoverHeight2 = jQuery('#sno_hoverbar').outerHeight();
	   	 		
					
				var CurrentScroll = 0;
				var WindowHeight = jQuery(document).height() - jQuery('.footerwrap').height();
				
									WindowHeight -= jQuery('#commentswrap').height();		
								
				
/*
				jQuery('.sno-menu').click(function() {
				
					jQuery('#hoverbar_menu').fadeToggle();
					jQuery('.menu-icon').toggle();
					jQuery('.close-icon').toggle();
					jQuery('#hoverbar_menu').css({ height: jQuery(window).height() - 50 });
				
				});
*/
				
				jQuery(window).scroll(function(event) {
					var NextScroll = jQuery(this).scrollTop();
	
					var ScrollPercent = (NextScroll / (WindowHeight - jQuery(window).height())) * 100;
					
	
					jQuery('#progress-bar-color').css({ width: ScrollPercent + '%'});
					jQuery('#hoverbar_menu').css({ top: jQuery('#sno_hoverbar').height() });
					
/*
					if ( ScrollPercent > 100 ) {
												jQuery('.sno-arrow-up').css({ background: '#081851', color: '#eee'});
						jQuery('.sno-menu').css({ background: '#081851', color: '#eee'});
						jQuery('.socialmedia .sharing-icon').css({ opacity: 1 })
						
							
					} else {
												jQuery('.sno-arrow-up').css({ background: '#eee', color: '#ccc'});
						jQuery('.sno-menu').css({ background: '#eee', color: '#ccc'});
					}
*/
					var headerLocation = jQuery("#wrap").offset().top;
					if (NextScroll > CurrentScroll && jQuery(document).scrollTop() > headerLocation) {
						if (jQuery('#sno_hoverbar').is(":hidden")) {
							jQuery('#sno_hoverbar').show();
							jQuery('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
								
														
															var lpb = jQuery('.lf_headerleft').width();
								lpb += jQuery('#sno_hoverbar .sno-menu').width(); 								var rpb = 50 + jQuery('.socialmedia').width();
																	rpb += jQuery('#sno_hoverbar .sno-search-button').width();
																jQuery('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
								        			}
	
	
	        			
					} else if (NextScroll < CurrentScroll && jQuery(document).scrollTop() < ( headerLocation + 300 ) && jQuery('#sno_hoverbar').is(":visible")) {
						
							jQuery('#hoverbar_menu').hide();
							jQuery('.close-icon').hide();
							jQuery('.menu-icon').show();
							jQuery('#hoverbar_menu').hide();
							jQuery('#sno_hoverbar').stop().animate({
								top: '-50px'
								},300, function(){
									jQuery('#sno_hoverbar').hide();
								});
							if ( jQuery('.navbarwrap').length ) { jQuery('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
							if ( jQuery('.subnavbarwrap').length ) { jQuery('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }
	
					}
				CurrentScroll = NextScroll;
				});
	
	
			});
	
		</script></body></html>